Back to overview
Degraded

Power Outage - Burleigh Waters PoP

Apr 28 at 09:00am AEST
Affected services
QLD Services

Resolved
Apr 28 at 02:02pm AEST

Power backup solution installed and operational. Electricians are still working on restoring the main power to the PoP. We will provide updates as necessary.

Created
Apr 28 at 09:00am AEST

Start Time: Monday, 28th April 2025

Impact: Loss of service for users within the Burleigh Waters catchment area.

Cause: Mains power outage affecting Freedom Internet infrastructure at the local Point of Presence (PoP).

Action: Technicians are en route to deploy battery-powered generators to restore services.
Work is underway with highest priority to reinstate connectivity today.

Current Status:
- Technicians dispatched
- Power backup installation in progress
- Monitoring restoration progress

Next Update:
Further update will be provided once services are restored or if additional information becomes available.
We appreciate your patience as we work to restore service.